Crypto Withdrawals delayed
Incident Report for Paxos
Resolved
This incident has been resolved - withdrawals are unblocked and are being fulfilled as normal now.
Apologies for any inconvenience caused.
Posted May 13, 2021 - 14:58 EDT
Identified
Some crypto withdrawals are delayed currently, we are investigating but it appears to be an issue with our identity provider, who is aware of the issue and working to restore service.
Posted May 13, 2021 - 14:37 EDT
This incident affected: Archive (Crypto Transfers).