Crypto Withdrawals and SEN Processing Issue
Incident Report for Paxos
Resolved
We are continuing to investigate this issue.
Posted May 07, 2021 - 05:43 EDT
Update
We are continuing to investigate this issue.
Posted May 07, 2021 - 05:20 EDT
Update
We are continuing to investigate this issue.
Posted May 07, 2021 - 04:39 EDT
Investigating
We are currently investigating this issue.
Posted May 07, 2021 - 01:51 EDT
This incident affected: Archive (US Dollar Transfers, Crypto Transfers).