Paxos - Crypto Transfers Delayed (ETH)

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 17:23 UTC

Identified

We are currently experiencing delays in processing crypto withdrawals on Ethereum. Customers may continue submitting these, but processing times may be longer than usual. Our team has identified the issue and we are implementing a fix.
Posted Sep 16, 2026 - 16:58 UTC
This incident affected: Dashboard UI (Crypto Transfers) and Paxos v2 API (Crypto Transfers).