Paxos - Dashboard web UI incident identified

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 13:04 UTC

Investigating

We are currently experiencing an authentication issue in the Dashboard portal. As a result, customers may encounter problems signing in or signing up at dashboard.paxos.com. The issue is intermittent, and in some cases a retry may succeed.
Our Engineering team is actively investigating and working to resolve the issue.
Posted Jul 31, 2026 - 12:32 UTC
This incident affected: Dashboard UI (Dashboard Web UI).