Paxos - Crypto Transfers Incident Detected

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 20:23 UTC

Monitoring

The issue has been resolved. The backlog of pending withdrawals to the Ethereum network should be processed shortly.
Posted Jun 04, 2025 - 19:55 UTC

Identified

Our Engineering team is actively working on a resolution.
Posted Jun 04, 2025 - 19:10 UTC

Investigating

At this time, we are experiencing an outage on the Transfers endpoints. As such, Crypto Withdrawals to Ethereum network are impacted and customers may experience delays in processing.
Posted Jun 04, 2025 - 16:46 UTC
This incident affected: Paxos v1 API (Crypto Transfers), Dashboard UI (Crypto Transfers), account.paxos.com UI (Crypto Transfers), and Paxos v2 API (Crypto Transfers).