Paxos - Wire Deposits Incident Identified

Incident Report for Paxos

Resolved

The incident is resolved and all wire deposits have been processed.
Posted Jul 19, 2024 - 20:27 UTC

Identified

The issue with Fiat Transfers has been identified. Please expect delays with Wire Deposits processing.
Posted Jul 19, 2024 - 16:50 UTC
This incident affected: account.paxos.com UI (USD Transfers) and Paxos v1 API (Fiat Transfers).