Verification is currently underway for the maintenance items.
Posted May 07, 2025 - 10:44 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 07, 2025 - 09:30 UTC
Scheduled
Prior to the upcoming Ethereum Pectra Fork, Paxos will pause on-chain Ethereum network (ETH/ERC-20) transfers at approximately 09:30 UTC on May 7, 2025. The Ethereum Fork is scheduled to take place on May 7, 2025 10:05:11 UTC. Consequently, all deposits and withdrawals on the Ethereum network will be delayed.
Once the fork has completed and we confirm the stability of the new network, we will notify you to resume your transfer activities. You can expect services to be restored approximately 2-4 hours after the upgrade.
We do not anticipate any disruption to trading during this period. You will continue to be able to trade all Paxos-supported crypto assets on the Paxos platform.
We will send out reminders via status.paxos.com 60 minutes before we pause on-chain Ethereum network transfers.