Paxos - Crypto Transfers Incident Detected

Incident Report for Paxos

Resolved

The issue has been resolved, all crypto withdrawals should be processed now.
Posted May 24, 2025 - 22:12 UTC

Monitoring

Engineering has implemented the fix in the system, and all pending withdrawals should be processed shortly.
Posted May 24, 2025 - 20:33 UTC

Update

Withdrawals to the Solana network remain under investigation by Engineering. Withdrawals to other crypto networks are currently processing and clearing the backlog.
Posted May 24, 2025 - 19:23 UTC

Identified

The Engineering team is actively working to enhance the performance of the backlog processing for crypto withdrawals.
Posted May 24, 2025 - 18:14 UTC

Monitoring

Engineering has applied the fix, and we are now processing the backlog of pending crypto withdrawals.
Posted May 24, 2025 - 17:05 UTC

Identified

Engineering has identified the root cause and is actively working on a resolution.
Posted May 24, 2025 - 15:01 UTC

Investigating

We are experiencing an outage with Crypto Withdrawals to all networks. Customers can continue initiating withdrawals on platform, but may experience some delays with transfers on chain.
Posted May 24, 2025 - 12:33 UTC
This incident affected: Dashboard UI (Crypto Transfers), account.paxos.com UI (Crypto Transfers), and Paxos v2 API (Crypto Transfers).