Paxos - Delays Processing Fiat Withdrawals

Incident Report for Paxos

Resolved

Our banking partner has processed the outstanding fiat withdrawals, the incident is resolved
Posted Aug 26, 2026 - 01:29 UTC

Identified

We are currently experiencing delays processing fiat withdrawals for a subset of users specific to a banking partner. Withdrawal requests can still be submitted, but completion may take longer than usual. We are working with our banking partner to investigate and will provide another update as more information becomes available.
Posted Aug 25, 2026 - 23:00 UTC
This incident affected: Dashboard UI (Fiat Transfers) and Paxos v2 API (Fiat Transfers).