Paxos - Fiat Transfers Incident Detected

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 19:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2025 - 19:49 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 14, 2025 - 14:13 UTC

Investigating

We are currently experiencing a delay in processing Fiat Withdrawals for PTE customers. Customers can continue to submit withdrawals but may experience delays in processing. Fiat Withdrawals via CUBI is currently not affected.
Posted Aug 14, 2025 - 12:47 UTC
This incident affected: account.paxos.com UI (USD Transfers), Dashboard UI (Fiat Transfers), and Paxos v2 API (Fiat Transfers).