Paxos - Crypto Transfers Incident Detected

Incident Report for Paxos

Resolved

All Crypto Deposits should be processed now.
Posted May 19, 2025 - 12:44 UTC

Identified

The issue with Crypto Withdrawals has been resolved. We are processing a backlog of Crypto Deposits on Solana network, which should take around 13 hours to complete.
Posted May 19, 2025 - 00:39 UTC

Investigating

At this time, we are experiencing an outage on the Transfers endpoints. As such, Crypto Withdrawals and Deposits are impacted and customers may experience delays in processing.
Posted May 18, 2025 - 22:56 UTC
This incident affected: account.paxos.com UI (Crypto Transfers), Archive (Crypto Transfers), and Paxos v2 API (Crypto Transfers).