Paxos - Paxos platform incident detected

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:52 UTC

Update

- Dashboard access has been restored.
- We are now processing the backlog of transfers; it may take some time to fully catch up.
Posted Oct 20, 2025 - 18:42 UTC

Update

Paxos services remain impacted by the ongoing outage on AWS infrastructure.
- Crypto withdrawals are experiencing delays.
- Users may be unable to sign in to the Dashboard portal.
Posted Oct 20, 2025 - 17:23 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 16:05 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 16:00 UTC

Identified

We are currently experiencing an outage in our AWS environment that is impacting the Paxos Dashboard portal and Crypto Transfers. As a result, some users may be unable to sign in to the Dashboard; Crypto Withdrawals processing is delayed. Our Engineering team is actively working to resolve the issue.
Posted Oct 20, 2025 - 15:13 UTC
This incident affected: Dashboard UI (Crypto Transfers, Dashboard Web UI), account.paxos.com UI (Crypto Transfers), and Paxos v2 API (Crypto Transfers).