Paxos - Exchange Incident Identified

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted Mar 13, 2023 - 18:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2023 - 18:13 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 13, 2023 - 18:09 UTC

Investigating

We have detected a delay in order execution times and are currently investigating. We will send a status update in the next 30 minutes or earlier.
Posted Mar 13, 2023 - 18:04 UTC
This incident affected: Paxos v2 API (Trading - Orders), FIX (FIX Trading), account.paxos.com UI (Trading), and Archive (itBit REST API - Trading).