Paxos - Crypto Transfers Incident Detected

Incident Report for Paxos

Resolved

All delayed Deposits on Solana network should be processed now.
Posted Jul 30, 2025 - 21:59 UTC

Identified

We've identified an issue that caused some Solana crypto deposits submitted between 17:00 and 20:00 UTC to be delayed in processing. Our engineering team is actively working to process these impacted deposits as quickly as possible. We’ll keep you updated as soon as all pending transactions are resolved.
Posted Jul 30, 2025 - 21:24 UTC
This incident affected: Dashboard UI (Crypto Transfers), account.paxos.com UI (Crypto Transfers), and Paxos v2 API (Crypto Transfers).