Paxos Sandbox - Dashboard portal incident identified

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted May 22, 2026 - 16:21 UTC

Investigating

We are currently experiencing an issue with the Dashboard Portal in the Sandbox environment.
As a result, SSO login is not working for the Sandbox Dashboard Portal at this time.
Engineering is actively investigating and working on a resolution.
Posted May 22, 2026 - 15:46 UTC
This incident affected: Paxos Sandbox.