Commodities Settlements Processing - Incident Identified
Incident Report for Paxos
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 08:37 EDT
Update
We are currently rolling out a fix and all functionality will be back to normal within a few minutes.
Posted Mar 27, 2024 - 08:13 EDT
Update
We are currently working on a fix on this issue and should have this implemented in the next few minutes. We will send a status update in the next 30 minutes or earlier.
Posted Mar 27, 2024 - 07:42 EDT
Identified
Please note we have detected an issue with Settlement processing not working as expected. The issue affects manual actions on the settlement dashboard such as "pay counterparty" that currently does not work. The settlement service itself is otherwise fully operational.

Engineering is investigating the root cause at the moment. We will send a status update in the next 30 minutes or earlier.
Posted Mar 27, 2024 - 07:10 EDT
This incident affected: Commodities Settlement Processing (Netting, Settlement, Settlement Notifications).